Akeeba Backup for WordPress requires PHP 7.1.0 or later but your server only has PHP 7.0.33-0ubuntu0.16.04.16.